海蜘蛛用户手册-主页--->企业三层交换网络解决方案

企业三层交换网络解决方案

目录

50.1. 路由上不划分VLAN
50.1.1. 路由器设置
50.1.2. 三层交换机设置
50.1.3. 常见问题及解答
50.2. 在路由器上划分VLAN
50.3. 启用DHCP服务
50.4. 启用PPPoE服务

网络拓扑图如下所示:

网络拓扑图

图 50.1. 网络拓扑图


由上图可知,现在交换机上划分四个VLAN ,每个VLAN的接口地址如上图所示,现将交换机VLAN1接口与海蜘蛛路由LAN口相连,各VLAN通过VLAN1上网。

50.1. 路由上不划分VLAN

50.1.1. 路由器设置

  1. 添加静态路由

    “网络设置”->“静态路由”,添加静态路由如下图所示:

    启用静态路由

    图 50.2. 启用静态路由


  2. 为VLAN网络加入NAT上网支持

    默认情况下,只有和路由局域网IP在同一网段的机器才能上网。进入“网络设置”->“局域网 (LAN)”,在VLAN网络地址栏里添加三层交换上所划分的VLAN网络,如下:

    VLAN网络

    图 50.3. VLAN网络


    此时,三层交换下的各VLAN网络里的客户机都可以通过路由联入互联网了。

50.1.2. 三层交换机设置

这里以华为s3526c为例,配置如下:

#
vlan 1
#
vlan 2
#
vlan 3
#
vlan 4
#
interface Vlan-interface1
 ip address 172.16.1.1 255.255.255.0
#
interface Vlan-interface2
 ip address 172.16.2.1 255.255.255.0
#
interface Vlan-interface3
 ip address 172.16.3.1 255.255.255.0
#
interface Vlan-interface4
 ip address 172.16.4.1 255.255.255.0
#
interface Aux0/0
#
interface Ethernet0/1
 flow-control
#
interface Ethernet0/2
 flow-control
#
interface Ethernet0/3
#
interface Ethernet0/4
#
interface Ethernet0/5
#
interface Ethernet0/6
#
interface Ethernet0/7
 port access vlan 2
#
interface Ethernet0/8
 port access vlan 2
#
interface Ethernet0/9
 port access vlan 2
#
interface Ethernet0/10
 port access vlan 2
#
interface Ethernet0/11
 port access vlan 2
#
interface Ethernet0/12
 port access vlan 2
#
interface Ethernet0/13
 port access vlan 3
#
interface Ethernet0/14
 port access vlan 3
#
interface Ethernet0/15
 port access vlan 3
#
interface Ethernet0/16
 port access vlan 3
#
interface Ethernet0/17
 port access vlan 3
#
interface Ethernet0/18
 port access vlan 3
#
interface Ethernet0/19
 port access vlan 4
#
interface Ethernet0/20
 port access vlan 4
#
interface Ethernet0/21
 port access vlan 4
#
interface Ethernet0/22
 port access vlan 4
#
interface Ethernet0/23
 port access vlan 4
#
interface Ethernet0/24
 port access vlan 4
#
interface GigabitEthernet1/1
#
interface NULL0
#
 ip route-static 0.0.0.0 0.0.0.0 172.16.1.2 preference 60
       
       
       

50.1.3. 常见问题及解答

客户机不能上网

  • 检查线路连接是否正确

  • 确保客户机设置的网关为其所属VLAN的IP地址,使用ping命令ping路由LAN口IP,若不通,则交换机默认路由设置错误