海蜘蛛用户手册-主页--->单WAN口通过交换机扩展接入多线路解决方案

单WAN口通过交换机扩展接入多线路解决方案

目录

51.1. 单WAN口通过交换机扩展接入多ADSL解决方案
51.1.1. 网络拓扑结构
51.1.2. 三层交换机上的配置
51.1.3. 路由上的配置
51.1.4. 采用支持VLAN的二层交换机
51.2. 单WAN口通过交换机扩展多个固定IP解决方案
51.2.1. 单WAN口通过交换机扩展接入同一ISP的多个固定IP
51.2.2. 单WAN口通过交换机扩展接入不同ISP的多个固定IP

51.1. 单WAN口通过交换机扩展接入多ADSL解决方案

实例分析:某网吧现有20条ADSL线路,通过海蜘蛛路由实现带宽叠加上网,由于主板上资源有限,同时插上20块网卡无疑不太现实,而且很难保证每块网卡都能正常工作。此时,通过交换机来扩展 ADSL 接入无疑是一个非常好的选择。

51.1.1. 网络拓扑结构

基于多猫的网络拓扑结构

图 51.1. 基于多猫的网络拓扑结构


基于光纤以太网的网络拓扑结构

图 51.2. 基于光纤以太网的网络拓扑结构


  • 通过建立以上的网络拓扑结构,就可以实现路由上只有一个WAN口时仍然可以接入多条ADSL线路。

  • 这种方法有效的解决了多网卡IRQ冲突问题以及当用户有多条ADSL接入时PCI插槽不够的问题。

51.1.2. 三层交换机上的配置

  1. 华为 s3526c 配置示例

    由于有20条ADSL需要接入,故需要在三层交换机上划分20个VLAN,每个VLAN中只包括一个端口,每个端口与一根ADSL相连。以华为s3526c为例,交换机配置如下所示:

    #
    interface Ethernet0/1
     
    #
    interface Ethernet0/2
      port access vlan 2
    #
    interface Ethernet0/3
      port access vlan 3
    #
    interface Ethernet0/4
      port access vlan 4
    #
    interface Ethernet0/5
      port access vlan 5
    #
    interface Ethernet0/6
       port access vlan 6
    #
    interface Ethernet0/7
      port access vlan 7
    #
    interface Ethernet0/8
     port access vlan 8
    #
    interface Ethernet0/9
     port access vlan 9
    #
    interface Ethernet0/10
     port access vlan 10
    #
    interface Ethernet0/11
     port access vlan 11
    #
    interface Ethernet0/12
     port access vlan 12
    #
    interface Ethernet0/13
     port access vlan 13
    #
    interface Ethernet0/14
     port access vlan 14
    #
    interface Ethernet0/15
     port access vlan 15
    #
    interface Ethernet0/16
     port access vlan 16
    #
    interface Ethernet0/17
     port access vlan 17
    #
    interface Ethernet0/18
     port access vlan 18
    #
    interface Ethernet0/19
     port access vlan 19
    #
    interface Ethernet0/20
     port access vlan 20
    #
    interface Ethernet0/21
     
    #
    interface Ethernet0/22
     
    #
    interface Ethernet0/23
     
    #
    interface Ethernet0/24
    

    这里用24号端口与海蜘蛛路由WAN接口相连,24号端口不需要划入任何VLAN,默认属于VLAN1即可。

    交换机上24号端口的配置:

    #
    interface Ethernet0/24
    port link-type trunk
    port trunk permit vlan all
    dot1x
    
  2. H3C S3600 配置示例

    #
    interface Ethernet1/0/1
    
    #
    interface Ethernet1/0/2
     port access vlan 2
    #
    interface Ethernet1/0/3
     port access vlan 3
    #
    interface Ethernet1/0/4
     port access vlan 4
    #
    interface Ethernet1/0/5
     port access vlan 5
    #
    interface Ethernet1/0/6
     port access vlan 6
    #
    interface Ethernet1/0/7
     port access vlan 7
    #
    interface Ethernet1/0/8
     port access vlan 8
    #
    interface Ethernet1/0/9
     port access vlan 9
    #
    interface Ethernet1/0/10
     port access vlan 10
    #
    interface Ethernet1/0/11
     port access vlan 11
    #
    interface Ethernet1/0/12
     port access vlan 12
    #
    interface Ethernet1/0/13
     port access vlan 13
    #
    interface Ethernet1/0/14
     port access vlan 14
    #
    interface Ethernet1/0/15
     port access vlan 15
    #
    interface Ethernet1/0/16
     port access vlan 16
    #
    interface Ethernet1/0/17
     port access vlan 17
    #
    interface Ethernet1/0/18
     port access vlan 18
    #
    interface Ethernet1/0/19
     port access vlan 19
    #
    interface Ethernet1/0/20
     port access vlan 20
    #
    interface Ethernet1/0/21
    
    #
    interface Ethernet1/0/22
    
    #
    interface Ethernet1/0/23
    
    #
    interface Ethernet1/0/24
    
     port link-type trunk
     port trunk permit vlan all
    

每种交换机配置都不全一样,具体配置请参考各交换机的VLAN配置说明书。

51.1.3. 路由上的配置

进入 Web管理 ->“网络设置”-> “广域网(WAN)”,选择相应的WAN口,选择ADSL/PPPoE拨号的Internet接入方式,填入用户名和密码,如下图所示:

[重要] 重要

在主界面拨号的账号所对应的ADSL线路为默认接入交换机VLAN1接口的ADSL线路。

单击后面的“在此WAN口上绑定多个账号”:

进入多账号配置,如下图所示:

[重要] 重要

每个账号对应的VLAN ID必须与交换机上划分的VLAN ID相对应,这里的VLAN ID唯一,不能有2个账号有相同的VLAN ID号。

同样的方法,继续新增另外的账号。

拨号成功后,可以在对应的网卡界面查看线路监测日志,掉线后会自动切换:

在路由主页面上也会有相应的线路显示,如图:

51.1.4. 采用支持VLAN的二层交换机

支持VLAN的二层交换机也可以实现扩展多 ADSL 接入,比使用三层交换机具有成本更低的优势。

网络结构图与通过三层交换机扩展多ADSL接入方案一致。

二层交换机图例

  .-------------------------------------+
 /           3c17203                   /|
+---+---+---+----------------------+--+ |
| 1 | 3 | 5 |   ...                |23| |
+--+---+---+--------------- -------+--+ |       
| 2| 4 | 6 |    ...     12 ...     |24|/ 
+---+---+---+-----------|----------+-+     
                        |                       +------------------+
                         ---------------------- | Hi-Spider Router |-------- 二层交换机 ---- 客户机
                                    tagged标签  +------------------+       
                                             
     
     
     

有多少条ADSL需要接入,就需要在二层交换机上划分对应数量的VLAN,每个VLAN中只包括一个端口,每个端口与一根ADSL相连,这里以3c17203二层交换机接入2条ADSL为例,交换机配置如下所示:

  1. 创建VLAN2 ,具体命令如下图所示:

       
     Menu options: --------------3Com SuperStack 3 Switch 4400---------------
     create             - Create a VLAN
     delete             - Delete a VLAN
     detail             - Display detailed information
     modify             - Modify a VLAN
     summary            - Display summary information
    
    Type "quit" to return to the previous menu or    for help
    ----------------------------------------- (1)---------------------------
    Select menu option (bridge/vlan): create
    Select VLAN ID (2-4094)[2]: 2
    Enter VLAN Name [VLAN 2]: vlan 2
             
       
       

    将交换机端口2划入VLAN2,划分成功后将一根ADSL接入端口2,具体命令如下图所示:

       
             Select menu option (bridge/vlan): modify
    
    Menu options: --------------3Com SuperStack 3 Switch 4400---------------
     addPort            - Add a port to a VLAN
     name               - Name a VLAN
     removePort         - Remove a port from a VLAN
    
    Type "quit" to return to the previous menu or    for help
    ----------------------------------------- (1)---------------------------
    Select menu option (bridge/vlan/modify): addport
    Select VLAN ID (1-5)[1]: 2
    Select bridge port (1-24,AL1-AL4,all)[all]: 2
    Enter tag type (untagged,tagged): untagged
             
     
     
  2. 同样的方法创建VLAN3 ,并将交换机端口3划入VLAN3 ,划分成功后将另一根ADSL接入端口3

  3. 将交换机端口12与海蜘蛛路由wan口连接,并将端口12同时划入VLAN2和VLAN3 ,并设置tagged标签,设置成功后查看端口12信息如下图所示:

       
    Select menu option (bridge/port): detail
    Select bridge port (1-24,AL1-AL4): 12
    
    Unit 1, Port 12 Detailed Information
    
    State:                Forwarding        fwdTransitions:         9
    StpCost:                      18        BroadcastStormControl:  Enabled
    DefaultPriority:               0
    
     VLAN ID             VLAN Name           Tagging Mode
    -------------------------------------------------------------------------------
    1                   Default VLAN        Tagged
    2                   vlan 2              Tagged
    3                   vlan 3              Tagged
             
     
     
    [重要] 提示

    通过以上设置可以得知,与路由相连的交换机端口即中继端口必须设置成属于每个VLAN

    例:如果有20根ADSL接入,中继端口必须设置成同时属于20个VLAN

路由器上的配置和通过三层交换机扩展多ADSL接入方案一致。